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Prerequisites for running this example

» There are several hardware and software tools necessary in order to
run this example:

— MCB1760 or MCB1750 Evaluation Board from Kaeill

— LPC1700 Code Bundle software package

— PC with 2 USB ports and 125MB of available hard disk space
— Keil MDK-ARM IDE (free eval version is ok)

— FlashMagic In-System Programming software and PC serial port — OR —
ULINK2 / ULINK—-ME JTAG debugger

» Please refer to the LPC1700 Sample Code Bundle Introduction / Setup
file (code.bundle.lpcl7xx.keil.intro.setup.pdf) for more details on setting
up the hardware and software environment

— This file can be found here:
http://www.standardics.nxp.com/support/sofiware/code bundle.lpcl 7xx.keil/
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Example Description

» The Audio project is a demo program for the Keil MCB1700 Board using
the NXP LPC17xx Microcontroller

» It demonstrates an USB Audio Device - Speaker

» The USB Audio Device is recognized by the host PC running Windows
which will load a generic Audio driver and add a speaker which can be
used for sound playback on the PC

» Potentiometer on the board is used for setting the Volume

» Since DMA is used for ISO communication, the USB RAM is allocated
for DMA purposes. A scatter file, dma.sct, is used in the Kelil project file
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Running the USB AUDIO example
from the LPC1700 Sample Code
Bundle using the ULINK2 or
ULINK-ME JTAG debugger



Note: instead of ULINKZ2 you

USB AUDIO example using JTAG debugger
Step 1: Hardware Setup
» Make sure your computer and your board are connected as shown

» This powers the board, provides USB device connection to the PC, and
provides JTAG debugging / flash programming

Note: Position USB
jumpers as shown below
(VBUS jumper is closed):

Note: Remove the RST USB Ports
and ISP jumpers on the
MCB1700 board:

can also use ULINK-ME:
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USB AUDIO example using JTAG debugger
Step 2: Opening up the Keil uVision3 project

» Open the project by double-clicking on the following file here:
. -\LPC17xxSampleSoftware . xxx\Kei IN\USBAudio\usbaudio.uv2

— Note: Ignore all the ‘invalid path’ warnings if you see some (just click ‘OK’)

» Familiarize yourself with the following files:

h -

audio.h
adcuser.h
adcuser.c
usb.h
usbaudio.h
usbcfg.h
usbcore.h
usbcore.c
usbdesc.h
usbdesc.c

y
A

USB Audio related header

USB Audio Device Class user specific header
USB Audio Device Class user APIs

USB header

USB Audio misc. definition header

USB configuration header

USB Core header

USB Core APIs

USB descriptor header

USB descriptor APIs
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USB AUDIO example using JTAG debugger
Step 2: Opening up the Kell project (cont.)

— usbhw.h USB hardware header

— usbhw.c USB hardware APIs

— usbreg.h USB misc. register header

— usbuser.h USB user header

— useuser.c USB user APIs

— usbmain.c USB Audio test module

— usbaudio.uv2 uVision project file

— dma.sct uVision scatter file for use of DMA

— system_ LPC17xx.c: Cortex-M3 Device Peripheral Access Layer Source File
(CMSIS—compliant)

— startup_LPC17xx.s: CMSIS Cortex-M3 Core Device Startup File (CMSIS—compliant)
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USB AUDIO example using JTAG debugger
Step 3: Compiling the example project
» Make sure the uVision3 Target setting is ‘FLASH’  &|FLasH M

» Build the project clicking the “Rebuild all target files”-button )

» Example should build without errors or warnings

Euild target 'Flash'

compiling ushbuser.c...

comwpiling ushoore.c. ..

comwpiling ushdesc.c...

cowpiling ushdmain.o. ..

compiling ushhw.c...

compiling adcuser.c...

compiling system LPC1Txx.o. ..

compiling core cmid.c...

assenbling startup LPC1Vxx.s...

linking...

Program Size: Code=6404d4 FO-data=55Z RW-data=88 ZI-data=1344
FromELF: creating hex file...
rohvChivushaudio.axf™ - 0 Error(s), 0 Warningis).
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USB AUDIO example using JTAG debugger
Step 4: Programming the code to on-chip Flash

Select Flash as the target (if not already done)  a<rLasH El

i

i

Make sure JTAG debugger is connected to PC and board

Click on the LOAD button to start download 3

i

i

Verify that the download is ok (in the Build window)

Erase Done.
Prograrmming Done.
Verify QK.

i

Please note that the code is not running yet...
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USB AUDIO example using JTAG debugger
Step 5: USB Audio device enumeration

» Remove ULINK / ULINK-ME from the board

» Press RESET button to start code execution

» PC should indicate device enumeration

i) Found New Hardware

Your new hardware is installed and ready ko use,

[l

» The USB connection between the MCB1700 board and the PC now not
only provides power to the board but also connects the MCB1700 to the
PC as an Audio Device via USB
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USB AUDIO example using JTAG debugger
Step 6: Verifying USB device enumeration

» Make sure the potentiometer on the MCB1700 (= volume) is not all the
way down to O

» Start an mp3 file (e.g. in Windows Media Player)

» You should hear the song playing from the MCB1700
(via isochronous USB transfers)

i Speaker EEX
Cptions  Help

Speaker W ave St Sunth CD Player

Balance: Balance Balance Balance:

p 4 |53 460 9T <
olurme: olure: Yolume: olurme:

() L L) L

[T Mute al [ Mute [ Mute [ Mute

MXP LPC1 7w Speaker
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USB AUDIO example using JTAG debugger
Step 7: Verifying the Device Manager

» On your Desktop, click on “My Computer”

» Click on “Control Panel” [ control panel
» Double-Click on “System” ¥8system
» Click on the “Hardware” tab Hardware . |

» Click on “Device Manager” [_bevesterss ]

 Under “Sound, video and game controllers", a new USB Audio Device
ShOUld be Shown =9 gultbd?;dgsdincg game controllers

@, Legacy Audio Drivers

] Leqacy Wideo Capture Devices
@), Media Control Devices LISB Audio Device Properties
/] SlgmaTeI ngh Deﬁnltlnn Audio CODEC

General | Properties | Driver | Details

@ USB Audio Device
)

‘E' '-.-'u:leu:u Cu:udeu:s

» Double-click it to see the full information:

Device twpe: Sound, video and game contrallers
b arufacturer: [Generic USE Audio]
Location: Location O [M=P LPC17xx Speaker |
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Running the USB AUDIO example
from the LPC1700 Sample Code
Bundle using the FlashMagic ISP
software



USB AUDIO example using FlashMagic
Step 1. Hardware Setup
» Make sure your computer and your board are connected as shown

» This powers the board, provides output from the UARTSs to the PC, and
provides for ISP programming

USB Ports £ Serial Port

Note: Position USB
jumpers as shown below
(VBUS jumper is closed):

Note: Make sure the RST
and ISP jumpers are closed
on the MCB1700 board:

Serial
Cable

......
e !
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USB AUDIO example using FlashMagic

Step 2: Opening up the Keil uVision3 project

» Open the project by double-clicking on the following file here:
. -\LPC17xxSampleSoftware . xxx\Kei IN\USBAudio\usbaudio.uv2

— Note: Ignore all the ‘invalid path’ warnings if you see some (just click ‘OK’)

» Familiarize yourself with the following files:

h -

audio.h
adcuser.h
adcuser.c
usb.h
usbaudio.h
usbcfg.h
usbcore.h
usbcore.c
usbdesc.h
usbdesc.c

y
A

USB Audio related header

USB Audio Device Class user specific header
USB Audio Device Class user APIs

USB header

USB Audio misc. definition header

USB configuration header

USB Core header

USB Core APIs

USB descriptor header

USB descriptor APIs
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USB AUDIO example using FlashMagic
Step 2: Opening up the Kell project (cont.)

— usbhw.h USB hardware header

— usbhw.c USB hardware APIs

— usbreg.h USB misc. register header

— usbuser.h USB user header

— useuser.c USB user APIs

— usbmain.c USB Audio test module

— usbaudio.uv2 uVision project file

— dma.sct uVision scatter file for use of DMA

— system_ LPC17xx.c: Cortex-M3 Device Peripheral Access Layer Source File
(CMSIS—compliant)

— startup_LPC17xx.s: CMSIS Cortex-M3 Core Device Startup File (CMSIS—compliant)
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USB AUDIO example using FlashMagic
Step 3: Compiling the example project

» Make sure the uVision3 Target setting is ‘FLASH’

» Build the project clicking the “Rebuild all target files”-button

» Example should build without errors or warnings

Euild target 'Flash'

compiling ushuser.c...

compiling ushoore.o. ..

compiling ushdesc.o. ..

compiling ushdmwain.c...

compiling ushhw.c...

compiling adocuser.oc...

compiling system LPCLIYxX.c...

compiling core cm3.c...

assembling startup LPC1Vxx.s5...

linking...

Program Zizse: Code=6404d4 BO-dats=552 RW-data=88 ZI-data=1344
FromELF:ocreating hex file...
"ohObihushaudio.axf™ — 0 Errori(s), 0 Warning(s) .

2 |FLASH

» As you can see, a .hex file is created in the progress...

— If not, check the ‘Create HEX File’ box under
‘Project > Options for Target ‘FLASH’ > Output’:

W Create HE File

A ¥ 4
4\
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USB AUDIO example using FlashMagic
Step 4. Setting up FlashMagic

» Make sure no other program is using the serial port
(e.g. TeraTerm, Hyperterminal, etc.)

» Make sure the serial cable is connected to the PC and to COMO

five

(=UARTO) on the MCB1700 board

» Launch FlashMagic application Flash Magic

» To make sure you're connected to the LPC1768, click
“ISP > Read Device Signature” and look for the following response:

Device Signature @

Device ID: 0R 26013F37

Bootloader Ver: 41

— If you get an error message instead, check your connections...

V1.0 August 2009 19

||
P



USB AUDIO example using FlashMagic
Step 5: Programming the code to on-chip Flash

3 M ake th e 'I:OI IOWi N g se I eCti ons: Step 1 - Communications Baud Rate: | 13200 b
Device: | LPC1768 w Interface: | None [I5P) W
COM Port: |COM 1 w Ozcillater [MHz); |12.000000

» Go to “Options > Advanced Options > Hardware Config”

— Make sure the following box is checked: |

Communications | Hardware Config | Security | Jus

dze DTR and RTS to contral RST and ISP pin

» Use the “Browse” button to select the USB HID project hex file:
...ALPC17xxSampleSoftware .xxx\kei IN\USBAudio\Obj\usbaudio.hex

Hes File: | Is\LPC P25 ampleS oftware. 1 01 4kl S BAudiod Objtusbaudio. hed

» Click Start!

— FlashMagic programs the selected
hex file into the LPC1768 Stan
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USB AUDIO example using FlashMagic
Step 6: USB AUDIO device enumeration
» The code should already be running...

» If not, press the Reset button to start code execution

» PC should indicate device enumeration

i) Found New Hardware

Your new hardware is installed and ready bo use,

[

» The USB connection between the MCB1700 board and the PC now not
only provides power to the board but also connects the MCB1700 to the
PC as an Audio Device via USB
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USB AUDIO example using FlashMagic
Step 6: Verifying USB device enumeration

» Make sure the potentiometer on the MCB1700 (= volume) is not all the
way down to O

» Start an mp3 file (e.g. in Windows Media Player)

» You should hear the song playing from the MCB1700
(via isochronous USB transfers)

i Speaker EEX
Cptions  Help

Speaker W ave St Sunth CD Player

Balance: Balance Balance Balance:

p 4 |53 460 9T <
olurme: olure: Yolume: olurme:

() L L) L

[T Mute al [ Mute [ Mute [ Mute

MXP LPC1 7w Speaker
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USB AUDIO example using FlashMagic
Step 7: Verifying the Device Manager

» On your Desktop, click on “My Computer”

» Click on “Control Panel” [ control panel
» Double-Click on “System” ¥8system
» Click on the “Hardware” tab Hardware . |

» Click on “Device Manager” [_bevesterss ]

 Under “Sound, video and game controllers", a new USB Audio Device
ShOUld be Shown =9 gultbd?;dgsdincg game controllers

@, Legacy Audio Drivers

] Leqacy Wideo Capture Devices
@), Media Control Devices LISB Audio Device Properties
/] SlgmaTeI ngh Deﬁnltlnn Audio CODEC

General | Properties | Driver | Details

@ USB Audio Device
)

‘E' '-.-'u:leu:u Cu:udeu:s

» Double-click it to see the full information:

Device twpe: Sound, video and game contrallers
b arufacturer: [Generic USE Audio]
Location: Location O [M=P LPC17xx Speaker |
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