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Prerequisites for running this example

There are several hardware and software tools necessary in order to 
run this example:

– MCB1760 or MCB1750 Evaluation Board from Keil

– LPC1700 Code Bundle software package

– PC with 2 USB ports, LAN port, and 125MB of available hard disk space

– Keil MDK-ARM IDE (free eval version is ok)

– FlashMagic In-System Programming software and PC serial port – OR –
ULINK2 / ULINK–ME JTAG debugger

– Crossover Ethernet LAN cable / serial cable (only if FlashMagic is used)

Please refer to the LPC1700 Sample Code Bundle Introduction / Setup 
file (code.bundle.lpc17xx.keil.intro.setup.pdf) for more details on setting 
up the hardware and software environment

– This file can be found here:
http://www.standardics.nxp.com/support/software/code.bundle.lpc17xx.keil/

http://www.standardics.nxp.com/support/software/code.bundle.lpc17xx.keil/
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Example Description

The EMAC project is a simple embedded web server for the NXP 
LPC17xx microcontrollers also known as “EasyWEB”

This tiny web server was taken from the 'Design & Elektronik‘ magazine 
extra issue 'Embedded Internet'.

– This software was adapted to work with a Keil MCB1700 board and the 
ARM RealView C-Compiler with as few modifications as possible 

The served web page shows the value of one analog input (AN2) which 
can be controlled via the blue potentiometer on the MCB1700 board
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Example Description (cont.)

EasyWEB needs very little resources and therefore has some 
restrictions:

– only one active TCP session at any one time

– no support for fragmented IP datagrams

– no buffer for TCP datagrams received in wrong order

– only one web page. No GIF/JPG graphics possible.

The IP address can be modified in the module tcpip.h to fit into your 
existing LAN (see MYIP_x)

At the end of this exercise you will be able to load, compile, execute and 
verify the operation of the EasyWeb example
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Running the EMAC / EasyWEB 
example from the LPC1700 Sample 
Code Bundle using the ULINK2 or 
ULINK-ME JTAG debugger 
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EasyWEB example using JTAG debugger 
Step 1: Hardware setup

Connect your Keil ULINK2 to your PC using the USB cable and to the 
MCB1700 via the JTAG connector

Connect the MCB1700 to your PC via the crossover Ethernet cable

USB
Cable 1

USB Ports

USB
Cable 2

Note: Remove the RST 
and ISP jumpers on the 

MCB1700 board: Crossover
Ethernet
Cable

Note: Move the E/C and 
the E/U jumpers on the 
MCB1700 board to the 

upper (E) position:

Note: instead of ULINK2 you 
can also use ULINK-ME:

http://www.keil.com/mcb1700/picture.asp
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EasyWEB example using JTAG debugger
Step 2: Opening up the Keil uVision3 project

Open the project by double-clicking on file “easyweb.uv2” here:
..\LPC17xxSampleSoftware.xxx\Keil\EMAC\easyWeb.uv2

– Note: Ignore the ‘invalid path’ warning if you see one (just click ‘OK’)

Familiarize yourself with the following files:
– tcpip.c: implements the TCP/IP-stack and provides a simple API to the user

– EMAC.c: Ethenet packet driver

– easyweb.c: implements a dynamic HTTP-server by using the easyWEB-API

– system_LPC17xx.c: Cortex-M3 Device Peripheral Access Layer Source File 
(CMSIS–compliant)

– startup_LPC17xx.s: CMSIS Cortex-M3 Core Device Startup File
(CMSIS–compliant)

– Abstract.txt: Describes what the EasyWEB example does



V1.0 August 2009 9

EasyWEB example using JTAG debugger
Step 3: Verifying the PC IP address

Open file tcpip.h by double-clicking it
This file holds the IP Address

Check the IP address of the EasyWeb code:
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EasyWEB example using JTAG debugger 
Step 4: Changing the PC IP address

Change the IP address on your PC so it’s in the same sub domain as 
your board:

– Open up a command window

– Type ipconfig (this will show the current setting)

– To change the IP address of your PC Ethernet adapter, do this:
• Open Windows Explorer

• Click “My Network Places”

• Click “View Network Connections”

• Right-click “Wireless Network Connection” and click “disable”

• Double-Click “Local Area Connection”
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EasyWEB example using JTAG debugger
Step 4: Changing the PC IP address (cont.)

• Click “Properties”

• Scroll to Internet Protocol (TCP/IP) and double-click it to open the Properties

• Click “use the following IP address” and enter an IP address that is in the same 
sub domain as the board, but different from it; e.g.:

• Click OK, then click OK again.

– Type ipconfig again in the command window to verify the IP address of 
your PC has changed:
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EasyWEB example using JTAG debugger
Step 5: Verifying the LAN setup

Make sure laptop and board are connected as shown below with the
Ethernet cable and the board is powered up

Make sure PC and board have an individual IP addresses – but in the 
same IP subnet:  192.168.0.xxx    For example:

IP address:
e.g. 192.168.0.101

IP address:
192.168.0.110

USB
Cable 1

USB Ports

USB
Cable 2

Crossover
Ethernet
Cable

http://www.keil.com/mcb1700/picture.asp


V1.0 August 2009 13

EasyWEB example using JTAG debugger
Step 6: Compiling the example project

Make sure the uVision3 Target setting is ‘FLASH’

Build the project clicking the “Rebuild all target files”-button

Example should build with no errors, no warnings
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EasyWEB example using JTAG debugger
Step 7: Programming the code to on-chip Flash

Select Flash as the target (if not already done)

Make sure JTAG debugger is connected to PC and board

Click on the LOAD button to start download

Verify that the download is ok (in the Build window)

Please note that the code is not running yet…
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EasyWEB example using JTAG debugger
Step 8: Starting a Debugging session

Click “Debug > Start/Stop Debug Session”

Click OK here (Evaluation Version Message)

Code will stop at main()

Hit ‘Run’ button
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EasyWEB example using JTAG debugger
Step 9: Pinging your board from your PC

Try to ping your board from your PC:
– Open up a command window

– Type ping 192.168.0.110 to ping your target board.

Note the orange LED (on the Ethernet connector of the MCB1700 
Board) flashes every time an Ethernet frame is received
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EasyWEB example using JTAG debugger 
Step 10: Accessing the web page

Open Internet Explorer

Go to “Tools > Internet Options > Connections > LAN Settings”
– Make sure no proxy servers are used
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EasyWEB example using JTAG debugger
Step 10: Accessing the web page (cont.)

Point your browser to http://192.168.0.110

Embedded web server page is displayed – change the potentiometer…
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EasyWEB example using JTAG debugger
Step 11: Closing the example

Click ‘Halt’ to stop the program execution

Click       to stop the debugging session

Go to “Project > Close Project” to close the project (if desired)

Click “File > Exit” to close uVision3 (if desired)
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Running the EMAC / EasyWEB 
example from the LPC1700 Sample 
Code Bundle using the FlashMagic 
ISP software
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EasyWEB example using FlashMagic 
Step 1: Hardware Setup

Make sure your computer and your board are connected as shown

This powers the board, provides the Ethernet connection between the 
MCB1700 to the PC, and provides for ISP programming

Note: Make sure the RST 
and ISP jumpers are closed

on the MCB1700 board: USB
Cable

Serial
Cable

COM0

Serial
Port

USB Port

Crossover
Ethernet
Cable

Note: Move the E/C and 
the E/U jumpers on the 
MCB1700 board to the 

upper (E) position:

http://www.keil.com/mcb1700/picture.asp
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EasyWEB example using FlashMagic 
Step 2: Opening up the Keil uVision3 project

Open the project by double-clicking on file “easyweb.uv2” here:
..\LPC17xxSampleSoftware.xxx\Keil\EMAC\easyWeb.uv2

– Note: Ignore the ‘invalid path’ warning if you see one (just click ‘OK’)

Familiarize yourself with the following files:
– tcpip.c: implements the TCP/IP-stack and provides a simple API to the user

– EMAC.c: Ethenet packet driver

– easyweb.c: implements a dynamic HTTP-server by using the easyWEB-API

– system_LPC17xx.c: Cortex-M3 Device Peripheral Access Layer Source File 
(CMSIS–compliant)

– startup_LPC17xx.s: CMSIS Cortex-M3 Core Device Startup File
(CMSIS–compliant)

– Abstract.txt: Describes what the EasyWEB example does
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EasyWEB example using FlashMagic 
Step 3: Verifying the PC IP address

Open file tcpip.h by double-clicking it
This file holds the IP Address

Check the IP address of the EasyWeb code:
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EasyWEB example using FlashMagic
Step 4: Changing the PC IP address

Change the IP address on your PC so it’s in the same sub domain as 
your board:

– Open up a command window

– Type ipconfig (this will show the current setting)

– To change the IP address of your PC Ethernet adapter, do this:
• Open Windows Explorer

• Click “My Network Places”

• Click “View Network Connections”

• Right-click “Wireless Network Connection” and click “disable”

• Double-Click “Local Area Connection”
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EasyWEB example using FlashMagic
Step 4: Changing the PC IP address (cont.)

• Click “Properties”

• Scroll to Internet Protocol (TCP/IP) and double-click it to open the Properties

• Click “use the following IP address” and enter an IP address that is in the same 
sub domain as the board, but different from it; e.g.:

• Click OK, then click OK again.

– Type ipconfig again in the command window to verify the IP address of 
your PC has changed:
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EasyWEB example using FlashMagic
Step 5: Verifying the LAN setup

Make sure laptop and board are connected as shown below with the
Ethernet cable and the board is powered up

Make sure PC and board have an individual IP addresses – but in the 
same IP subnet:  192.168.0.xxx    For example:

PC IP address:
e.g. 192.168.0.101

IP address:
192.168.0.110

USB
Cable 1

COM0

USB Ports
Crossover
Ethernet
Cable

Serial
Cable

Serial Port

http://www.keil.com/mcb1700/picture.asp
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EasyWEB example using FlashMagic 
Step 6: Compiling the example project

Make sure the uVision3 Target setting is ‘FLASH’

Build the project clicking the “Rebuild all target files”-button

Example should build with no errors, no warnings

As you can see, a .hex file is created in the progress…
– If not, check the ‘Create HEX File’ box under

‘Project > Options for Target ‘FLASH’ > Output’:
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EasyWEB example using FlashMagic 
Step 7: Setting up FlashMagic

Make sure no other program is using the serial port
(e.g. TeraTerm, Hyperterminal, etc.)

Make sure the serial cable is connected to the PC and to COM0 
(=UART0) on the MCB1700 board

Launch FlashMagic application

To make sure you’re connected to the LPC1768, click
“ISP > Read Device Signature” and look for the following response:

– If you get an error message instead, check your connections…
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EasyWEB example using FlashMagic 
Step 8: Programming the code to on-chip Flash

Make the following selections:

Go to “Options > Advanced Options > Hardware Config”
– Make sure the following box is checked:

Use the “Browse” button to select the EMAC project hex file:
…\LPC17xxSampleSoftware.xxx\keil\EMAC\FLASH\easyWeb.hex

Click Start!
– FlashMagic programs the selected

hex file into the LPC1768
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EasyWEB example using FlashMagic 
Step 9: Running the example

The program should already be running…

If not, press Reset Button to start code execution
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EasyWEB example using FlashMagic 
Step 10: Pinging your board from your PC

Try to ping your board from your PC:
– Open up a command window

– Type ping 192.168.0.110 to ping your target board.

Note the orange LED (on the Ethernet connector of the MCB1700 
Board) flashes every time an Ethernet frame is received
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EasyWEB example using FlashMagic 
Step 11: Accessing the web page

Open Internet Explorer

Go to “Tools > Internet Options > Connections > LAN Settings”
– Make sure no proxy servers are used
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EasyWEB example using FlashMagic 
Step 11: Accessing the web page (cont.)

Point your browser to http://192.168.0.110

Embedded web server page is displayed – change the potentiometer…
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